Some Xperia S users complaining of yellow tint display issue

by XB on 21st March 2012

in Problems, Xperia S


Now that the Sony Xperia S is out in many markets across the world, we are starting to hear about some users complaining about problems with their display. We’ve seen comments both on our forum and over at xda-developers about a yellow tint (or spot) towards the bottom of the handset. We’ve included some pictures below from different users that highlights the issue to varying degrees.

For some people, the yellow spot is very prominent, whereas for others they are seeing a yellow tint to the very bottom of the screen and is much harder to notice. It typically can be seen on a white background, for example when browsing. Just to be clear, our Xperia S exhibits none of these traits, so we imagine this affects a minority of units.

From the sounds of it, the first case seems like a display defect and people who have had this problem have had their handsets exchanged by Sony. Their new phones do not appear to have this problem. Regarding the yellow tint, it is difficult to know whether this is a display or software issue. It could simply be the glue that holds the display together that should vaporise over time. If anyone is experiencing any display problems then please let us know in the comments below.

Yellow spot issue

Yellow tint Xperia

Yellow tint Xperia

Yellow tint Xperia

Yellow tint issue

Yellow tint Xperia

Yellow tint Xperia

Previous post:

Next post:

Sitemap