New firmware (14.2.A.1.144) certified for the Xperia Z1 and Xperia Z1 Compact

by XB on 24th February 2014

in Firmware, Xperia Z1


Xperia Z1_C6903_14.2.A.1.144Sony Mobile has certified a new firmware build for the Xperia Z1 (C6903 only) and Xperia Z1 Compact (D5503) with version number 14.2.A.1.144. This is an incremental update to the last certified version (14.2.A.1.142) and could represent a carrier-specific update. We’ll keep you posted if/when it starts to roll out.

Xperia Z1_C6903_14.2.A.1.144

Xperia Z1 Compact_D5503_14.2.A.1.144

Thanks @craig_ord85!

  • techielover

    Xperia Sp/t/ after upgrading to 4.3 having the available ram to use is only 80 mb well anyone think they are caring anything about that….lol

  • Tim Westerholm

    It’s probably not the 4.4 update anyway

  • Oscar Fernando

    So no kitkat 4.4 update to z1 for atleast one month ?

  • Z1ZLIndia

    No just looks like a improvement in 4.3, but we want is KitKat :/

  • Timbo1

    It will be better to wait that month, have you seen how laggy the Z2 is in its current state with Kit Kat?

  • Supercow

    Android 4.4 in April for Z1, Z1 compact and Z Ultra ? http://smartphones.sfr.fr/android/tableau-des-mises-a-jour-sfr-mars-2014/

  • Chris

    Good on Sony for continuing to support 4.3 and trying to fix its bugs instead of waiting for kitkat.

  • Micro

    I don’t really care if it’s 4.4 or 4.3 again, I just hope they finally FIX THE FREAKING BLUETOOTH!

    Come on, do I really need to stick with the old 4.2.2 to be able to use bluetooth audio? :/ 4.3 ruins the phone for me :(((

  • Johan Eriksson

    What exactly is wrong with the bluetooth?

  • Micro

    the long story short – audio streaming (A2DP) is broken on any 4.3 I’ve tried, on 4.2.2 it works perfectly fine

  • Johan Eriksson

    I have the newest firmware (4.3) and it’s working perfectly with my bluetooth Soundbar. Actually better than before :)

  • Micro

    lucky you :(
    my one keeps disconnecting every several minutes with basically any BT device, and when I try to listen anything on literally any bluetooth audio device (headset, BT receiver, the computer, even car audio) the stream breaks within seconds after it’s started. 4.2.2 solves this just like that. And no other phone I own have such problems, it’s definitely the Z1@4.3 in my case
    I tried everything, all older firmwares, different customization firmwares, in fact, I flashed the whole Internet to this phone already – it happens on ALL 4.3 androids, on 4.2 there is no problem at all :((((

  • Carlos Jin

    How can I test my Z1 to see if A2DP is broken in my phone??

    I have a Sony BTX300 and a Nokia BH504 and it works well in both of them, but I´m not sure if I´m using A2DP or some other stuff..

  • Johan Eriksson

    That sucks. Really wierd that you’re not having any problems with 4.2 :S

  • Micro

    connect it to any aptX device, or any high quality audio device and play your music. Then enable BT on, let’s say, a laptop, or turn on another wireless device that THROW module is able to find, and just wait. Throw will start to scan for those other devices, regardless of having the first one already connected, and the horror will begin.

  • Johan Eriksson

    Well aint you a ray of sunshine :)

  • Pingback: ???????? Sony Mobile ???????????????? ????? ???????? ??? ?????????? Xperia Z1 ? Z1 Compact | IT-Info()

  • Micro

    it does, dude :( I had to downgrade.. it hurts :/
    is here anyone with SBH20 or, CSR BT stick (usb, 4.0 Class 1) or BM10 or any car audio who have a remedy?

  • vito_f_micro

    i have around 300mb, but as xperia t user dont wanna 4.4, just fix some bugs on 4.3 and i’ll be fine.

  • Johan Eriksson

    Hopefully everything will work perfectly for you when 4.4 is released!

  • Micro

    thanks mate.. I hope they have a fix with this new upcoming update :( it’s still 4.3 so.. the hope dies last :|

  • Brian Byron De Guzman

    I have SBH52 and it is working just fine.

  • Micro

    it works relatively fine with sbh20 too until another BT device able to play audio is in range :|

  • Timbo1

    weird, I have no problems with music streaming to any bluetooth output i have, works in both cars and NFC enabled devices I own. 4.3 C6902 .136 firmware.

  • Micro

    4.3 C6903 lte here :/ perhaps that’s why :(

  • Micro

    could you, please, copy 2 files from your /system/lib/hw and post a link?
    audio.a2dp.default.so and bluetooth.default.so ?
    AFAIK those two cause the problem, on 4.2 they were set to low quality streaming (the old audio problem), it’s “fixed” in 4.3 but since you have those two working fine… maybe this would help…

  • Micro

    could you, please, copy 2 files from your /system/lib/hw and post a link?
    audio.a2dp.default.so and bluetooth.default.so ?
    AFAIK those two cause the problem, on 4.2 they were set to low quality streaming (the old audio problem), it’s “fixed” in 4.3 but since you have those two working fine… maybe this would help…

  • Micro

    UPDATE: I took the risk and just flashed the baseband of my old 4.2.2 (only baseband) on the newest 4.3 firmware. And you know what? IT WORKED!! Everything works perfectly well again!
    So this really IS problem with the firmware, not hardware.

  • Stefano Cislaghi

    Does anyone is experiecing some strange noise after any sound like a form of distorsion?

  • Antares

    migliorate le foto che sono inguardabili con poca luce!!!!!!! potenzialmente lo z1 compact potrebbe essere il miglior smartphone di tutti i tempi non vi fate un autogoal così.

  • Laurence Keir

    I use an SBH 20, BT5V and Nissan Bluetooth a2dp with no problems on 4.3. I’ve north heard of any problems before!

  • Micro

    I flashed the baseband part of 4.2.2 FW and problem is gone.
    Flashed back 4.3’s one – the hell returns.
    Flashed old one again – runs like a charm.
    So the problem is there, question is – on all customization variants or not. It depends on specific model of course, I have different set of radio devices than 6902 models. My one is 6903 LTE, so I am aware that not everybody face the same issue. But it’s still there if I can easily reproduce/fix it. I hope the idea of flashing older baseband helps someone too.

  • cloud1704

    I don’t have any issue since moved to 4.3. Perhaps your phone specific. Kindly bring your nearest service center rather than make a fuss here.

  • Darren Gaspé

    Just go get a new phone.. (^o^)

  • FredrikAn

    Just give me Kitkat, please!

  • Mokhtar Mouhib

    yess me too

  • richard

    thank u . can i believe that information?? i just think about kikat will be update so late . i just want upgrade. anyway will be update in aprill

  • MisterB

    I have also many problems with the bluetooth on my Z1…. You’re not alone!

  • Micro

    yeah, I know I’m not.. this issue is very common (look at the google/android bug tracker or XDA forums, tons of it)

    perhaps you could try the baseband trick too, who knows
    it fixed 99% my problems with my BT (for now)

  • Mirrorpurple

    come on… faster release this…

  • j_ee

    No problem here as well. Neither 4.2.2 or 4.3.

  • Pingback: Xperia Z Ultra firmware certified (14.2.A.1.144) | Dek Droid()

  • Resonancer

    Sure thing, Blue tooth audio quality is bad!! My sony car audio system worked better with my 2yr old nokia. Shame on Sony.

  • Pingback: Neuigkeiten zu Offizielle Software - Updates aktuell C6903 14.2.A.0.290 Android 4.3 - Android-Hilfe.de()

  • notPerfect

    Hi! I’m new to this Android-stuff, just left iPhone for Z1 Compact. I have noticed that there is an issue regarding the bluetooth. In my car, a Volvo V50 (year model -11) the pairing works fine. But when trying to make calls, I only hear the first connecting tone in the car audio system before it switches over to the phone. Trying to click and choose “Bluetooth unit” again during the call doesn’t work.

    And today I received a bluetooth headset, SBH20, with the same problem. It works nice listening to music (phone ->headset) but phonecalls are switched back to the telephone almost immedeately.

    Streaming audio from the Z1 Compact to a Logitech Audio Bluetooth adapter works just fine.

    Have read something in this thread about baseband, and flashing something. Sounds like greek to me, but if someone could explain this and help me to solve this issue I would be most greatful. Please concider that my skills in Android-handeling are very limited.

  • Pingback: New Xperia Z1 update (14.2.A.1.144) rolls; only for Movistar in Spain | Xperia Blog()

  • Pingback: New Xperia Z1 update (14.2.A.1.144) rolls; only for Movistar in Spain | MOBILE361()

  • Ase

    Hello. I understand you. I own Z1 compact and have the same issue with KK. Music hiccups every 30-40 seconds. And it becomes even worse when I go outside the office and the phone tries to connect to other devices via Throw or smth. The new smartconnect app and throw are to blame… And I can’t downgrade to 4.2 since my phone initially came with 4.3

  • Divya Bharathi

    Very interesting thing I just come across at MyDeals247.com – I could choose any number of items (from the list) at very heavy discount rates (up to 75% off online) – more we buy more discount – I never seen this before.

Previous post:

Next post:

Sitemap