Camera app won't start

Discussion in 'Xperia arc and Xperia arc S' started by Rômulo, Apr 20, 2012.

  1. Rômulo

    Rômulo New Member

    Hello guys. I have a X Peria Arc LT15A, android version 2.34, build number 4.0.2.A.0.42.
    It's been a while since i'm having problems with my camera. once in a while it would stop working (when I was taking a picture, the flash light would just freeze and the app would close). Now, I can't even open the camera app. It says "the camera application has stopped unexpectedly, please try again" EVERY SINGLE TIME. Does anyone know how to fix this specific problem?

    I have tried changing firmware, reseting, etc. etc, nothing seems to work.
    Thanks in advance!
     
  2. Charl

    Charl Member

    Don't you have some kind of warranty? You should really just send it back and get it repaired...
    EDIT: Maybe upgrading to ICS will fix it.
     
  3. Rômulo

    Rômulo New Member

    Yeah, I thought about upgrading to ICS, already downloaded. I just wanted to try everything before that and before sending to support. Because it takes months to take my cell back if I send it to them.
    edit: I also don't know where my warranty papers are. I bought the phone on may of 2011. btw, does anyone know if it's a 1 year warranty or it depends on the store? (i bought it on sonystyle btw)
     
  4. Charl

    Charl Member

    I dunno about the warranty really... I could just go to the store, show the papers and they'll have it fixed for me, for free. It's a big company and they want to have a good reputation. But that's for me, I dunno about you..

    EDIT: By the way, I noticed now that you have an Arc and not an Arc S, so the official ICS release is about a month from now... Which brings me to the next point, rooting your phone with a custom ROM would cost you your warranty, I wouldn't risk that...