Root guide for ICS/JB Sony Xperia phones

Discussion in 'Xperia S and Xperia SL' started by Xperia Blog, Sep 23, 2012.

  1. Xperia Blog

    Xperia Blog Administrator Staff Member

    Thought I'd post a quick guide to rooting your Sony Xperia phone. Note this method will only work for phones on Android 4.0 Ice Cream Sandwich and Android 4.1 Jelly Bean.

    1. Download the latest script from xda-developers.

    2. Extract the RAR file and double click on the 'RunMe' batch file. Connect your handset and you should see a screen similar to the one below.

    [​IMG]

    3. Look at your phone and the 'Back up & restore' app will have appeared. Under Restore, click on "Select record to restore".

    [​IMG]

    4. Make sure you select "RootMe".

    [​IMG]

    Don't worry about clicking 'OK'.

    [​IMG]

    You will see the message below that the phone will now reboot.

    [​IMG]

    5. Congratulations - once the phone has rebooted you will see the message below. Your phone is now rooted.

    [​IMG]
  2. Mt Weg

    Mt Weg New Member

    does it work for Xperia Arc LT15i ?
  3. Xperia Blog

    Xperia Blog Administrator Staff Member

    As long as it is running ICS then I see no reason why not, although I haven't tried it on one.
  4. Mt Weg

    Mt Weg New Member

    I tried but its not working as I don't have the Sony Backup-restore.apk . Can you please let me know where to get it?
  5. Xperia Blog

    Xperia Blog Administrator Staff Member

    Did you try running in Normal mode instead of Sony mode?
  6. Mt Weg

    Mt Weg New Member

    yes, i used the normal mode.
  7. Xperia Blog

    Xperia Blog Administrator Staff Member

    You're right, it won't work. Bin4ry from xda said that Sony ripped out the native "adb restore" function from ICS. Looks like it won't work with the arc on ICS unfortunately.
  8. Metadonpatient

    Metadonpatient New Member

    Do I need unlocked bootloader? So, this method will just root my Xperia S? Does it work with my Swedish phone? Or region doesn't matter? Thanks for help and I hope you understand what I'm trying to say, my English isn't that good :confused:

    Skickat från Sony Xperia S (ICS 4.0.4)
  9. Xperia Blog

    Xperia Blog Administrator Staff Member

    No you don't need to unlock your bootloader. It will work with any Xperia S! :)
  10. Metadonpatient

    Metadonpatient New Member

    And this method works with the latest update (6.1.A.2.45)? :)
    Anyway, thanks for your help.

    Skickat från Sony Xperia S (ICS 4.0.4)
  11. Xperia Blog

    Xperia Blog Administrator Staff Member

    I don't see why not? I tried it using older firmware.

    You can always try it, it won't cause any damage. There is an option to Unroot using the above script too.
  12. waseem5053

    waseem5053 New Member

    sir plz help me work on this
    Xperia™ arc S ?
  13. Xperia Blog

    Xperia Blog Administrator Staff Member

    It won't work on the Xperia arc S unfortunatley.
  14. Snuki

    Snuki New Member

    Did this on my Xperia S and now its slows, if i try to go to the homescreen to the right Xperia home crashes, it doesnt vibrate when using the menu, home or back button and it doesnt help to choose unroot in the script.. help..

    edit: cant use album either.
  15. LiveSquare

    LiveSquare Member

    No one experience this sort of issues. Might be something wrong with your phone or the applications in it. Try to reinstall and try again with clean firmware.
  16. Xperia Blog

    Xperia Blog Administrator Staff Member

    Suggest the same as LiveSquare, seems like the firmware has corrupted. Try reinstalling firmware and then use above script.
  17. Snuki

    Snuki New Member

    I factory reset my phone and tried again and it did the same :/
  18. Joseph Boukaram

    Joseph Boukaram New Member

    Hy guy's i use it on my XS it work like charm . But now the phone reboot itself when it on standby any body can help ? and what is the problem ? Thank you
  19. LiveSquare

    LiveSquare Member

    I reinstalled my phone yesterday and used the same method (I think I used v13). I don't experience any of the issues you mentioned here. It should be your phone or may be you are doing something else other than the steps mentioned. Sorry, can't help!!
  20. LiveSquare

    LiveSquare Member

    Naa, this could be some of your apps misbehaving.

Share This Page