Help - bricked my Xperia S

Discussion in 'Xperia S and Xperia SL' started by magicshirts, May 24, 2012.

  1. magicshirts

    magicshirts New Member

    First of all, my apologies if I have posted this in the wrong place.
    I have successfully flashed firmware before, and was attempting to flash the new 73 firmware for my Xperia S.
    I think I may have connected my phone without having checked that USB debugging was on.
    The message that came up on Flashtool was Device connected with USB debugging off.
    I disconnected my phone. However, now my phone won’t turn on, and I fear I have bricked it.
    Flashtool won't recognise the device anymore.
    Can anyone please help?

    Thanks in anticipation

  2. LiveSquare

    LiveSquare Member

    Sony (Ericsson) phones are hard to brick unless you have messed up with your boot loader. Hope hope you didn't unlock and mess the boot loader.

    Try to reinstall the drivers and flash again using flashtool. There is a folder in flashtool which contains the necessary drivers. For flashing of firmware, you don't have to select the USB debugging.
  3. magicshirts

    magicshirts New Member

    Thanks for your reply. Pressing "power button and volume up" didn't work initially, which is why I was so worried. I really thought I'd bricked it. For some reason, it worked later on.
    I attempted flashing again, and received the same USB debugging warning. I then decided to turn my computer "off and on again" and it worked perfectly.
    I have now successfully updated to 6.0.A.3.73... just need to see if there is any improvement in the battery life..
  4. LiveSquare

    LiveSquare Member

    The .73 firmware surely improves the battery. Good luck.
  5. AwesomeRomeo

    AwesomeRomeo New Member

    Please help me, I switched on my Bluetooth and my xperia arc s lt18i went off. I switched it on but it stuck at xperia logo. I tried to boot it to recovery but it refused to boot to recovery. I tried PC companion but it says there's no update for my device. USB is not enabled, I try flashing the firmware but the firmware didn't appear in the flashtool. Please what should I do? Thanks.