phone shut down while upgrading

Discussion in 'Xperia S and Xperia SL' started by craig, Aug 5, 2012.

  1. craig

    craig New Member

    Just got an Xperia S and tried to upgrade it.

    I followed the instructions, but the phone was automatically shut down during the process of upgrading (while downloading software). It happened a few times and every time my phone had at least 70% of power to begin with.

    It's very frustrating and I had to give up upgrading.
    I'll really appreciate your help and any suggestions.
     
  2. LiveSquare

    LiveSquare Member

    Have you tried to upgrade using the SUS/SEUS?
     
  3. Being_human

    Being_human New Member

    Its the same thing happened to me today ..
    and my cell was not starting at all..
    not have to take it to sony service center. :(
     
  4. Sam Sylvester

    Sam Sylvester New Member

    I had the same problem.

    Don't connect your phone to the system using a USB hub or a USB extendor. Connect it directly to the USB port of the system. A hi-speed port is preferable (at the back of the CPU). Or try connecting to other ports.