Refuses to go into flash mode for update, USB connectivity problems...

Discussion in 'Xperia C4 and Xperia C4 Dual' started by ryoshenron, Jan 14, 2018.

  1. ryoshenron

    ryoshenron New Member

    After learning that there was a 6.0 Marshmallow update for the C4, even though my phone never found the update through the OTA check, even after telling it to manually check several times, I installed the Xperia PC Companion program on my computer to have it install the update on my phone. It downloaded the update and rebooted my phone, however, it did not successfully put the phone into flash mode to install the update. The program then instructed me to hold the "volume down" button while plugging in the USB cable to the PC. I tried this over and over several times, but every single time I try, the phone just goes into charging mode, and never allows the update process to continue. I tried several different USB cables, different ports on the PC, and even a different PC, and it never worked.

    I have also noticed that whenever I want to plug my phone into the PC to transfer files, many times it only starts charging and refuses to recognize a connection to the PC, and I often have to unplug and replug it a few times before both the PC and the phone recognize a USB connection and allow file transfer.

    Is there just something wrong with the USB port on my Xperia C4? Or could something else cause this problem? And if so, is there any way to install the 6.0 update without going through a PC? Why is the software update app on the phone not finding the update through the OTA check anyway? Any help on this would be appreciated. Thanks.

    BTW, this is the ES5306 US version of the phone, and it is the unlocked version, without any ties to a certain carrier.