Root guide for ICS/JB Sony Xperia phones

Discussion in 'Xperia S and Xperia SL' started by Xperia Blog, Sep 23, 2012.

  1. Joseph Boukaram

    Joseph Boukaram New Member

    thank you i will check my apps
  2. SAMURAI6969

    SAMURAI6969 New Member

    does this work on Xperia SL ????
  3. Highslayer

    Highslayer New Member

    Excuse my ignorance guys, but what does 'rooting' mean? What does it do?
  4. Highslayer

    Highslayer New Member

  5. Joseph Boukaram

    Joseph Boukaram New Member

    I have uninstall my apps one by one and my phone still rebooting every 24 hours i even reinstall the firmware from Sony PC Companion than rooted it with the last patch . But the problem still there so please what did i do wrong ???
  6. LiveSquare

    LiveSquare Member

    Do a clean install. Don't install anything, (not even root) run it as pure stock and check if the problem still there. Backup your internal memory and wipe that too, but don't copy back anything until you finish the testing.
  7. Joseph Boukaram

    Joseph Boukaram New Member

    The problem occur only when i root the phone . What i'm doing wrong ? Can you help.
  8. LiveSquare

    LiveSquare Member

    Its not easy to find out like asking question. You have to do some testing by yourself to find out since no one has complained such issues before.
  9. Sebastien

    Sebastien New Member

    I did everything up to step 4 (xperia s) but it says: running......
    It's been like that for an hour why isn't it working ?! :(

    -- It also says:
    Warning: Activity not started, its current task has been brought to the front

    what does that mean ?? Please help
  10. Steveveve

    Steveveve New Member

    I used this to root my Xperia Sola before the latest update it worked fine, but when I updated the phone, it became unrooted, and I tried this many many times and failed, I also tried Oneclickroot, Superoneclick and all of them failed, can anybody help me? desperate
  11. ste

    ste New Member

    If all is successful i will tell you, if not this shell will run forever.
    Running .......

    Im stuck in here right now. Please help
  12. Joseph Boukaram

    Joseph Boukaram New Member

    u can't root 6.1.A.2.55 in the normal mode use mode 3 to root it if it didn't work use the program (ERoot ) . I hope i answered your question