Wifi Problem since update

Discussion in 'Xperia P' started by famkej, Aug 15, 2013.

  1. famkej

    famkej New Member

    I've been using my Xperia P for more than a year now, and was quite happy with it. A couple of months ago, my phone was updated to version 4.0.4 of Android. Since that time, I have had a problem with Wifi.

    Every 3 or 4 days, the phone refuses to connect to my home network. My network is protected by WPA2/PSK. In the Wifi network display, it shows "saved, secured with 802.1x. If I press it to connect, it says the signal is excellent, but refuses to connect. No matter whether I restart my phone, restart my modem, the phone refuses to connect. There is only one way to make the connection: via any of the PC's in the house, (which is also connected via wireless, and does not have this problem), I change the channel on the modem, and the phone reconnects instantly. This works for a few days. The problem is not the channel; I toggle betweeen channels 4 and 11. I can even change from 4 to 11 back to 4 within 3 minutes of each other, and the phone connects. This is the only solution that works; powering down the modem, counting to 100 and restarting, powering down the phone, counting to 100 and restarting, does nothing.

    4.0.4 is the newest version available from my provider, so I cannot upgrade.

    Any ideas?
  2. yassashii

    yassashii New Member

    i got the same problem, wifi cant turn on
  3. Ben Duckworth

    Ben Duckworth New Member

    I see the same issue, I recently updowngraded from an HTC Desire to a Sony Xperia SP running JB 4.1.2 but every few days the wifi stops working completely, I have tried rebooting the phone, disabling wifi power saving feature, even adding a DHCP fixed host IP and disabling authentication in the router. The wifi drops out frequently and then sometimes completely fails to connect again reporting a variety of messages "Authentication Problem" "Failed to obtain IP address" "Disconnected" "Out of Range" During authenticatoin the signal strength drops to almost nothing.
    The is deeply frustrating and if I cannot resolve it I will have to revert to my 2 year old HTC with Gingerbread 2.3 which has never had any problems.
    I am sure it is not my router at fault as it works flawlessly with a number of other wireless devices.
    Sony please, please fix this! there are many reports online of this same issue.

    Just tried changing channels as suggested by famkej and indeed it now connects, thanks for the workaround. This needs propper investigation.
  4. Ben Duckworth

    Ben Duckworth New Member

    Bump - does anyone at Sony bother to monitor this forum ?