Xperia P ICS wifi issue.. Plzzz help..

Discussion in 'Xperia P' started by umairulhaq, Oct 18, 2012.

  1. umairulhaq

    umairulhaq New Member

    -Hi.. ive been using xperia p for last 1month with gingerbread 2.3.7.... Now ive just updated it to ICS 4.0.4... Now there is some WIFI issue... It's now not autoconnecting to wifi saved networks... i mean, whenver i click on wifi to turn it on, it doesnt select the SAVED NETWORK... instead i have to go into settings & manually connect to the saved network every single time...I have to do it everytime i turn on wifi...
    -With 2.3.7, i just had to click wifi icon and it wd automatically connent to the saved network... My router settings r normal.. my bro also has XP with 2.3.7 and it connects automatically to saved network just wid a single click, not going through this long procedure.. Let me add that i hav fresh clean install after format n factory reset... PLZ HELP SOME 1...
    - U can see the pic, wifi is on but not connected, i had to go into settings and connect it manually everytime ..
     

    Attached Files:

  2. Tobber1981

    Tobber1981 New Member

    Have exactly the same problem!
    Already posted it in the official SonyMobile-Forum but nothing helped...
    A friend of mine also has the same problems so I don't think they are isolated.
    Strange enough, your post is the first i found adressing this issue.
     
  3. Xperia Blog

    Xperia Blog Administrator Staff Member

    Did you guys manage to resolve this? Might be something we need to look into.
     
  4. umairulhaq

    umairulhaq New Member

    Mine is resolved by now... I have repaired it with Sony PC Companion... And luckily this time this problem is resolved... Let me tell u that since repair, i didnt turned on GPS and location services... May b it was causing the problem... Not sure... Sony should take a look into this and solve it so no body gets this issue again...
     
  5. Tobber1981

    Tobber1981 New Member

    Already repaired my as well with no luck.
    There's an option in WLAN options where you can turn of wifi when in standby. This works.
    Also the reconnect with ADVANCED STANDBY MODE is working flawlessly.
    It's just when I manually switch on WIFI at least 7 out of 10 times it just doesn't connect to a known wireless network...